General Functionality

From ETC Public Wiki
Jump to: navigation, search

File Operations

New Project

The level editor automatically starts a new project when the program opens. This creates a blank scene, blank user library, and loads the default library. To start another new project select the File Menu -> New Project.

New project.jpg

Open

To open a previously saved project go to File->Open. From there go to the folder containing your project file and load it. Please note that when you open a project file any unsaved information in your current project file will be lost.

Open.jpg

Save

To save a project file select File->Save

This dialog box will open.

Save1.jpg

First select the directory you wish to save the project in.

Save2.jpg

Then name the project file and click on the save button. This will create a number of folders in the folder you selected. These folders contain all of the assets that are associated with your project.

Folder Structure

When using the Storyteller, it generates a folder structure of chosen directory with key contents that would make running a game possible. The following structure is named: myProject

Conversations
This folder contains conversation files.
Journal_Entries
This folder contains journal entry files.
LEGameAssets
This folder contains all the necessities to make the basic world run. It's recommended to not alter this folder and the contents within it.
Models
This folder contains all of the files, mainly for meshs, actors, and animations.
Scripts
This folder contains all script files, both default and custom scripts.
Shaders
This folder contains all of the shader files.
Sounds
This folder contains all of the sounds for the project.
Textures
This folder contains all of the textured files and any movie files.
lib.index
This is the user's library index file.
myProject.journal
This is user's journal index file.
myProject.lbr
This is the user's exported library file.
myProject.proj
This is the main project file.
myProject.py
This is the main python file that the Storyteller generates that allows user to dig into the programming with support comments.
myProject.scene
This is a scene file. Depending on the number of scenes used for the world, there may be multiple .scene files.
runWorld.bat
This is the main batch file to execute and start the world.
Scripts.py
This is a python file that lists all the scripts used for the world.
Scripts.pyc
This is a python file that has been compiled for the world to run.

Viewport Manipulation

There are 4 basic viewports that the level editor provides:

  • Perspective
  • Top
  • Front
  • Left

All of the viewports save for the Perspective view are orthographic. You can have anyone of the viewports up at a time or all four at once. To switch viewports select Viewport->(View you want).

Viewport.jpg

The method to manipulate the viewports is the exact same method used in Maya.

  • To rotate or tumble the view hold the ‘Alt’ Key and Left Mouse Button. Then drag the mouse around the view to orient it.
    • Note: This function is disabled in the orthographic views
  • To Pan the view hold the ‘Alt’ key and Middle Mouse Button. Then drag the scene in any direction you wish.
  • To Zoom the view hold the ‘Alt’ key and the Right Mouse Button. Then drag the mouse down to zoom-in and drag the mouse up to zoom-out.

Merging Projects

The level editor has a basic merge scene function built in. It will merge in a project into the existing project. All merged objects will be loaded into their original location. Additionally all hierarchy, layer, and object property information is transferred.

In order avoid naming conflicts, the merge function prefixes all objects and assets loaded in with the name of the project it came from. This could potentially cause issues during the merge operation if you have items that are named the same as that. To circumvent this issue please avoid naming projects the same thing.

Additionally as this operation is more advanced, the error dialogs you get from this will be more severe and the level editor is more likely to crash. Make sure to save often.

To merge scenes do the following:

  1. Select->Merge
  2. Find the project you wish to merge with the current one
  3. Confirm the merge prefix is what you want to use
  4. Decide if you want to place everything from the merged scene under one node
  5. Click 'Merge'

You can merge as many scenes you want into the same one without issue.